Symptoms
- Error message: Activation is Currently Unavailable for Legacy Customers when trying to activate a 5.0 plan
Environment
- All Republic Wireless phones
- 5.0 plan
- Republic Wireless account with phones activated before 12/01/21
Resolution
If you intended to upgrade to a 5.0 plan, the plan must be purchased on an account that does not have any legacy (including My Choice) plans.
If you did not intend to upgrade to a 5.0 plan, call us at 866-550-9843 to request assistance with a return. Note that we are no longer able to activate legacy and My Choice SIM cards.
Cause
All phones purchased in our online store after 12/1/21 work on our 5.0 plans only. These 5.0 plans cannot be on the same account as a legacy plan. See: Information for Existing Republic Wireless Members Considering Moving to a 5.0 Plan for additional information.
Article Created From
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