Symptoms
- Switched to annual payment option without meaning to
Environment
- All Republic Wireless Phones on the My Choice (4.0) Plan
- Annual payment option
Resolution
If you have not yet been billed:
- Sign-in to your online account portal
- Under the service line that was switched to the Annual payment option, click the Up Arrow next to I WANT TO...
- Click Manage My Plan
- In the Pending Change box, click Cancel
If you have been billed
- Open a Help Ticket so we can assist you
Cause
The annual payment option was accidentally selected
Article Created From
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1706185