Accidentally Switched to Annual Payment Option

Symptoms

  • Switched to annual payment option without meaning to.

Environment

Resolution

  1. If you would like to save your voicemails (they will be lost in the next step) then save any voicemail messages you want to keep

  2. Open a Help ticket (if you have not already) and let us know about the accidental switch to the annual payment option as well as a good time to cancel your service

  3. We will cancel your service line and provide you with a coupon for a month of free service

  4. You will activate your phone using the provided coupon code

  5. Let us know when the phone is activated and we will restore your number to your phone

Cause

Annual Payment option was accidentally selected ("pocket ordered")

Additional Notes

The annual payment option provides two (2) months of free service! If you can manage the single payment, it may be worthwhile to keep the payment.


Article Created From

  • 1706185

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)