Moto X4 Activating on New CDMA iSIM - no Cellular Signal/Empty Signal Bars

Symptoms

  • Empty cell signal bars after CDMA activation with NEW CDMA SIM card
  • Persistent 'Configuring your cellular network' notification on the phone
  • Persistent 'No Network Connection' notification when not connected to a WiFi network
  • The Republic Wireless App continues to automatically re-enable WiFi antenna (because the phone detects no cellular signal connection)

Environment

  • Moto X4 
  • New CDMA iSIM activation (when the phone was activated on GSM previously)
  • Android Version: 9 - Build Number: PPW29.69.39-1
  • Android Version: 9 - Build Number: PPW29.69.39-2

Resolution

  1. Manually Toggle the phone's network mode to reset its modem settings. To do that: 
    • open the settings app
    • tap Network & internet
    • tap Mobile network
    • tap Advanced, next to the down arrow
    • tap Preferred network type - by default it should be set to Global
    • tap the button next to LTE (recommended) - at this point, you should see some cellular signal display in the top right corner of the phone screen
    • tap Preferred network type once more
    • tap Global to return the preferred network type back to the default setting and the phone should be able re-establish a stable cellular connection
  2. If toggling the network mode is unsuccessful, try resetting the phone's network settings
  3. If all the above options are unsuccessful, Factory reset the phone
    • after the factory reset is complete the new CDMA SIM card should be able to successfully connect to the CDMA cellular towers

Cause

Motorola confirmed that their underlying Android software contains a system bug. If a Moto X4 is provisioned to a GSM network and then receives a CDMA SIM card, it will be unable to automatically update is preferred network settings (and must be done manually via the resolution steps above).

The Moto X4 is not scheduled to receive anymore software ROM updates, so this bug will not be resolved by Motorola.

Additional Notes

It is possible that this issue impacts other Motorola phones (especially ones that have received a software update recently).


Article Created From

  • 1635996

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)