When Downloading Republic Wireless App on Nexus 6, Receiving Error: "Republic App Incompatible with Device"

Symptoms

  • "Republic app incompatible with device"

Environment

  • Nexus 6
  • Google Play Store 
  • Any Android Build before MTC19X

Resolution

Cause

The earliest Nexus 6 build that Republic Wireless supports is MTC19X

 

______________________________________________________________________________

Article Created From

  • 1443975

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)