Republic Wireless App Shows as "Incompatible" with Moto X Pure Edition

Symptoms

  • Unable to install the Republic Wireless application on the Moto X Pure Edition
  • Getting error "App isn't compatible with this phone or version"

Environment

  • Moto X Pure Edition
  • Android 5.1 Lollipop
  • Build LPH23.116-18

Resolution

Update the phone's software to Android 6.0 Marshmallow

Cause

Some Moto X Pure Edition phones may ship with Android 5.1 Lollipop installed, with build LPH23.116-18, as that was the initial launch build for the phone.  However, the correct Republic Wireless application requires a phone with Android 6.0 Marshmallow and above to install.

 

______________________________________________________________________________

Article Created From

  • 1440860

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)