"Not Authorized" When Attempting to Change Data Plan After a Device Swap

Symptoms

  • "Not authorized" error message shown when attempting to change data plan after a device swap
  • Using SIM card from a prior 3.0 phone in current 3.0 phone

Environment

  • All Republic Wireless 3.0 Phones
  • Original SIM card

Resolution

Cause

Incorrect IMEI information showing in our systems

Additional Notes

While making plan changes is done on the phone's Republic Wireless app, If you were to log into your Account Portal before following the resolution, you'll likely see that your original phone's IMEI is showing  


Article Created From

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