Activation Stuck on "Checking Network"

Symptoms

  • Phone stuck on "Checking Network" during the activation process

Environment

  • Samsung Galaxy S8

Resolution

  1. Check Network Settings 
  2. How to Perform Basic WiFi Troubleshooting

Cause

Without a strong WiFi connection during activation, the phone may become stuck during the "checking network" step and prevent the device from activation


Article Created From

  • 1376057

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)