Error: This Device Does Not Exist on Your Account

Symptoms

  • Notification that device is not activated
  • Error message when logging into Republic Wireless app: "This device does not exist on your account"

Environment

  • Moto G5 Plus
  • CDMA

Resolution

  1. Refresh the Republic Wireless Activation
  2. Update the data profile

Cause

Phone and SIM card not synced correctly with Republic Wireless servers

Additional Notes

This issue can sometimes be caused by switching directly from one CDMA SIM card to another. In that case, please activate the phone on with a GSM SIM card and then switch back to the CDMA SIM card that was initially installed.


Article Created From

  • 1348556

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