Symptoms
- Telephone number transfer to a different provider did not complete
Environment
Resolution
- Reactivate phone on same account
- Create a ticket requesting telephone number restoration
- Confirm restoration is completed by checking your telephone number within the Republic Wireless app or your account management page
- Resubmit number transfer with your new provider
Cause
- Service line is deactivated before telephone number transfer completed successfully
Additional Notes
- A telephone number restoration is time sensitive, reach out to Republic Help at earliest convenience regarding this issue via a Help Ticket
Article Created From
- 1317892