Can I Have a My Choice Plan on My 1.0/2.0 Phone?

 No longer supported

The phone(s) described in this article can no longer be activated with Republic. Please see Republic Wireless Phones for information on currently supported phones.

Environment

Republic Wireless 1.0 and 2.0 Phones

Answer

No, Republic Wireless Legacy Phones are compatible with only our 1.0/2.0 plans. This is because the Republic Wireless 1.0 and 2.0 plans rely on the unique ROM build of our earlier phones, and our 3.0 phones use an all-new architecture that moves us out of the ROM. 

 

 


Article Created From

  • 1311241

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)