Samsung Free is Using All Of My Data

Symptoms

  • Unexpected data usage from the Samsung Free application.

Environment

  • All Samsung Phones running Android 11 or higher.

Resolution

  1. From the home screen, swipe right to open the Samsung Free application.
  2. If prompted, select your privacy preferences, and then tap I agree.
  3. Tap on the 3 vertical dots at the top right corner.
  4. Tap on Settings.
  5. Ensure that Stream Over Wi-Fi only is enabled.  (Slider to the right)
  6. Ensure Auto Play and Autoplay next are disabled. (Slider to the left)

Alternatively, if you do not use this feature on your Samsung phone, you can disable Samsung Free completely:

 

How to Disable or Uninstall an App from Settings

 

Cause

Samsung Free has replaced Samsung Daily and Bixby Home on Android phones running Android 11 or higher.  This service has video feeds and news updates that occur via streaming services, which require a healthy amount of internet service to function.

Article Created From

  • 2096924

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)