Can't Send or Receive MMS or Retrieve Voicemail

Symptoms

  • Can't send or receive MMS
  • Can't retrieve visual voicemail

Environment

The following phones if they have not been updated to Android 8 or newer

  • Alcatel A30
  • Google Pixel*
  • Google Pixel XL*
  • Huawei Ascend 5W
  • Moto E (1st Gen)
  • Moto E (2nd Gen)
  • Moto E4
  • Moto E4+
  • Moto G (1st Gen)
  • Moto G (3rd Gen)
  • Moto G4
  • Moto G4+*
  • Moto G4 Play
  • Moto G5+*
  • Moto G5S+*
  • Moto X (1st Gen)
  • Moto X (2nd Gen)
  • Moto X Pure
  • Moto X4*
  • Moto Z*
  • Moto Z Play*
  • Moto Z2 Play*
  • Nexus 5X*
  • Nexus 6
  • Nexus 6P*
  • Samsung Galaxy J3 (2016)
  • Samsung Galaxy J3 (2017)*
  • Samsung Galaxy J7 (2017)*
  • Samsung Galaxy S6
  • Samsung Galaxy S7*
  • Samsung Galaxy S7 Edge*
  • Samsung Galaxy S8*
  • Samsung Galaxy S8+*
  • Samsung Note 8*

* Note: Some phones on the above list may have been able to update to Android 8 or above since their initial manufacture build.

Resolution

Update the Republic Wireless app

 

Additional Notes

Cause

A server security update requires updated security certificates on older phones

 


Article Created From

Support need

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)