Symptoms
- After entering Credit Card information receives error message "Failed to Authenticate Using Your Republic Wireless Account"
Environment
- Activating
- All Republic Phones
Resolution
- Contact your banking institution or credit card company to ensure there are no holds or blocks on your account preventing your activation order from being processed
- After ensuring no such blockages are in place, re-attempt activation
Cause
The banking institution or credit card company associated with the payment method entered is preventing the order from fully processing.
Article Created From
- 1287852