"You Do Not Have Permission" Error When Attempting a Plan Change

Symptoms

  • Unable to change the plan
  • "You do not have permission to change the plan on this phone. Please sign in as the account owner of this phone to continue."

Environment

Resolution

  1. Tap Sign Out in the top right corner of the app
  2. Tap Sign In at the bottom of the app
  3. Log in as the Owner of the account
    • Only account owners can change plans.
  4. Attempt to change the plan
  5. If you continue to receive this error when logging in as an account owner, please open a Help Ticket including the following information:
    • The IMEI of the phone on which you are attempting a plan change
    • The email address with which you are attempting to log in to the app

Cause

  • In order to change the plan on a Republic Wireless phone, the account owner must log in to the Republic Wireless app
  • In some cases, the current device being used isn't registering correctly with our systems after the SIM card was swapped to it. This requires a ticket to confirm and resolve

Article Created From

  • 1242677

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