"Invalid SIM Card" Message Received During Activation

Symptoms

  • "Invalid SIM card" message shows in the Republic Wireless application 
  • May receive the message "Unfortunately, we're unable to activate this SIM card. Please contact our Help team."

Environment

Resolution

If the SIM card being used was deactivated more than 20 days ago:

  1. Order a new SIM card from our online store

 

If the SIM card being used is brand new or is a CDMA SIM card:

  1. Open a Help Ticket or respond to your existing ticket
  2. Provide Information About Your SIM Card in the Help Ticket
    • Note: you'll need a WiFi connection to complete this step

Cause

Previously-activated GSM SIM cards can only be reactivated for up to 20 days.

See also: Why Does a SIM Card Expire 20 Days After Deactivation?

See also: Is My Republic Wireless SIM Card CDMA or GSM?


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