"Invalid SIM Card" Message Received During Activation

Symptoms

  • "Invalid SIM card" message shows in the Republic Wireless application 

Environment

Resolution

If the SIM card being used was deactivated more than 20 days ago:

  1. Order a new SIM card from our online store

 

If the SIM card being used is brand new:

  1. Open a Help Ticket or respond to your existing ticket
  2. Provide Information About Your SIM Card in the Help Ticket
    • Note: you'll need a WiFi connection to complete this step

Cause

3.0 phone SIM cards can only be reactivated for up to 20 days


Article Created From

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