Connectivity Problems on Cell/WiFi and SIM Errors on Moto E4

Symptoms

  • Republic Wireless app asks you to "buy a SIM card"
  • Phone may show error "SIM card not ready" 
  • Phone may show error "Authentication Error. Could not authenticate this device. Please make sure you have an active data connection. If this persist, please reboot your device."
  • Unable to call or message
  • No service/data coverage on WiFi or Cellular networks

Environment

  • Moto E4
  • Build numbers before NPQ26.69-41-4-1

Resolution

Cause

There was an issue with an early version of the software which caused an issue with the modem on the phone. Updating the Build number on the phone to version NPQ26.69-41-4-1 will resolve this issue.

Additional Notes

For information on how to check your Build number, see How to Locate the Phone's Build Number


Article Created From

  • 1236804

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