Symptoms
- Phone did not activate and switch over the phone number
- The phone isn't working
Environment
- New Moto Z Play purchased with a different or new account
- Activation with a current Republic Wireless number
- The phone has been fully setup
Resolution
- Sign into the Republic Wireless app
- Note: You'll want to use the Republic Wireless account which manages the number you want moved to the phone
- Tap the option to move the phone number to the new phone
- Confirm that the plan, phone number, and credit card being charged are all correct
- Tap Submit Activation
Cause
A phone number is stored under one account with Republic Wireless at a time, and to see the phone number during activation, you have to be logged into that account, rather than being logged into the account which purchased the phone.
Article Created From
- 1215971