No longer supported for new activation
While still supported for service, the phone(s) described in this article can no longer be activated on My Choice or other legacy plans. Please see Phone Compatibility on 5.0 Plans for information on currently supported phones.
Symptoms
- Phone will audibly ring or vibrate
- Option to answer or decline the call does not appear
- If you open the Phone application while the phone is still ringing, you see an option to "return to call in progress"
Environment
- All Republic 1.0/2.0 phones (excluding DEFY XT)
Resolution
- Open Settings
- Tap Sounds & Notifications
- Tap App Notifications
- Tap Dialer
- Ensure the slider next to Block is to the left
Cause
Notifications for the Dialer app is blocked which would prevent a call from appearing on the screen
Additional Notes
This can sometimes occur when you accidentally press and hold on a notification for a missed call or some other notification related to the Dialer app. This will allow you to directly go to the app notification settings where Block can sometimes be enabled by mistake.