Republic Wireless App Only Shows "Checking Info" When Trying to Activate

Symptoms

  • Republic Wireless app shows "Checking Info"
  • Unable to activate

Environment

Resolution

  1. Check the WiFi settings to make sure you are connected to a network
  2. Open the Play Store app on your phone and sign in to or create your Google account
  3. Update the Republic Wireless application

Cause

The phone needs to be connected to a WiFi network and the Republic Wireless application needs to be updated before you can complete the activation.


Article Created From

  • 1203914

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)