"Unsupported Phone" Error When Using an Old CDMA SIM Card to Activate a Phone Not Bought Directly From Republic Wireless

Symptoms

  • Unable to activate a phone not directly purchased from Republic Wireless using an old SIM card
  • Receives a message the phone is unsupported when inserting the SIM card
  • Phone may be a manufacturer replacement phone or a phone a member purchased on their own

Environment

  • Bring Your Own Phone (BYOP) activation
  • Original SIM card is CDMA

Resolution

  1. Make sure that your phone's Software Channel and Build Number are compatible with Republic Wireless 
  2. Request a CDMA SIM card: How to Request a 3.0 CDMA SIM Card (unless you already have a compatible CDMA SIM from us for the same model of phone that has been deactivated less than 20 days ago)
  3. Once the CDMA SIM card arrives, turn off your phone and install the CDMA SIM card
  4. Turn on your phone and follow the activation process

Cause

A CDMA SIM card cannot be used to activate a phone if that SIM card was deactivated more than 20 days ago.

Additional Information

Republic Help may require additional information regarding the phone.  Additionally, the phone must be compatible with CDMA service


Article Created From

  • 1195514

Having trouble finding the answer you’re looking for? Ask an Expert Member.
(Our Experts are not staff, but their knowledge of our service and phones is outstanding!)